My pond pump isn't working

If your pond pump is not working always fully read and check the troubleshooting section within your product instruction manual first.

A few good checks on all pond pumps that can help are below.

Important: Disconnect mains electricity supply before handling or attempting maintenance. Always fully read and check the troubleshooting section within your product instruction manual. 

Please open the unit up and inspect the impeller and shaft for any damage or blockages. Is the plastic propeller part attached to the magnet body of the impeller, or has it come apart or split? If the shaft or impeller has snapped or become damaged, this will need to be replaced.
Replacement impellers and shafts are available on our website please click here

If these parts looks fine and there are two rubber grommets fitted on each end of the shaft, or already inside the fittings, then re-assemble the unit.

Is your pond pump receiving water? If your pump is not fully submerged and has run dry, this may be your issue. Your pump may have a vapour lock, caused by an air bubble getting trapped in the pump. In this situation your impeller will be spinning, but no water is being pushed. This can be fixed by angling your pump to allow the air to escape. You may even be able to achieve this without disconnecting the fitting on pump.

Is there any power at all or is it completely dead? Please can you change the fuse to rule out this cause.

Still unsure why your pond pump is not working? Please contact our customer service team who will be happy to assist with some additional troubleshooting.